Can't install patch 8.7 over my 8.6 ?

  • I acquired ELITE v8.6, together with the full European Scenery database, the MEL TQ and the GNS 530 modules ( both USB ).

    Yesterday I noticed a patch could be downloaded from:

    Patches & Updates

    namely v8.7 (P.01) supposedly requiring that:

    “You will need a minimum V8.6.x version software prior updating the ELITE Software engine.”

    I am on Windows 10 Pro 64 bit. When I run the patch executable I get an error message stating that “no valid ELITE install was found” ?

    Any ideas ?

    I also contacted the Support through email today, and was already notified a ticked was opened.

You must be logged in to reply to this topic.